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Introduction

Easy Kanban Board is a powerful visual task management plugin for Unreal Engine 5.5+ that

brings professional Kanban workflow directly into your editor. Organize your game development

tasks, track progress, and maintain focus without switching between external tools.

Key Features

Visual Workflow - Drag-and-drop cards between customizable columns

Rich Task Details - Multi-line descriptions, priority colors, and custom tags

Flexible Organization - Create unlimited columns and configure your ideal workflow

Real-time Search - Instantly filter cards by title or description

Multiple Boards - Manage separate boards for different projects or teams

Auto-Save - Your work is automatically saved as you make changes

Import/Export - Share boards via JSON files with team members

Board Templates - Quick-start templates for common workflows

Editor Integration: Easy Kanban Board is designed exclusively for the Unreal Engine editor

with zero runtime overhead on your game.



Getting Started

Installation

Opening the Kanban Board

Access the Kanban Board in two ways:

Main Menu: Window → Easy Kanban Board

Toolbar: Click the Kanban Board icon in the Level Editor toolbar

First Launch: The board opens with a demo template to help you get started. You can

customize it immediately or create a new board from scratch.

Install from Fab Marketplace

Download and install Easy Kanban Board from the Fab Marketplace to your Unreal Engine

installation.

1

Enable the Plugin

Open your project, go to Edit → Plugins, search for "Easy Kanban Board" and enable it.

2

Restart Unreal Engine

Close and reopen your project for the plugin to fully initialize.
3



Figure 1: Easy Kanban Board main interface with columns and cards

Quick Start Tutorial

Open the Board

Click Window → Easy Kanban Board to open the main interface.
1

Create Your First Card

Click the "+ Add Card" button in any column. Enter a task title and description.

2

Add Details

Click a card to edit it. Add a priority color, tags, and detailed description.
3

Move Cards

Drag cards between columns to update their status as work progresses.
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Working with Cards

Creating Cards

Cards represent individual tasks or work items on your board.

1. Click the + Add Card button at the top of any column

2. A new card appears with an editable title field

3. Click the card to open the full editor dialog

Card Properties

Property Description

Title Short, descriptive name for the task (appears on the card)

Description Multi-line detailed notes about the task (viewable when editing)

Priority Color Visual indicator with 10 color options to categorize importance

Tags Comma-separated labels for categorization and filtering

Created Date Automatically recorded timestamp when the card was created

Modified Date Automatically updated whenever the card is edited

Editing Cards

To edit a card's details:

1. Click anywhere on the card

2. The Card Editor dialog opens with all editable fields

3. Make your changes

4. Click Save or press Enter to confirm

5. Click Cancel or press Escape to discard changes



Auto-Save: Changes to cards are automatically saved to disk. You don't need to manually

save the board.

Figure 2: Card editor dialog showing all editable fields

Priority Colors

Choose from 10 distinct priority colors to visually organize your cards:

Blue - Default/Standard priority

Red - Critical/Urgent tasks

Green - Low priority/Optional

Yellow - Medium priority/Warning

Purple - Feature requests

Orange - Review needed

Pink - Design/Creative tasks

Cyan - Technical tasks

Teal - Documentation

Gray - Blocked/On hold



Using Tags

Tags help you categorize and filter cards across your board:

Enter tags as comma-separated text: animation, character, urgent

Tags appear as small badges on the card

Use the search box to filter by tag names

Common tag examples: bug, feature, art, code, level-design, polish

Moving Cards

Cards can be moved in two ways:

Drag and Drop

1. Click and hold on a card

2. Drag it to another column or position

3. Release to drop it in the new location

Visual Feedback

Cards highlight when hovering during drag

Drop zones appear between cards and at column tops/bottoms

Invalid drop locations are clearly indicated

Deleting Cards

1. Click on the card to open the editor

2. Click the Delete button

3. Confirm the deletion when prompted

Warning: Deleting cards is permanent and cannot be undone. Make sure you want to

remove the card before confirming.



Working with Columns

Understanding Columns

Columns represent stages in your workflow. Common column setups include:

Backlog → To Do → In Progress → Review → Done (Software Development)

To Do → Doing → Done (Simple Workflow)

Ideas → Drafting → Review → Published (Creative Pipeline)

Adding Columns

1. Click the + Add Column button in the toolbar

2. A new column appears at the right end of the board

3. Click the column title to rename it

4. Customize the accent color in the column header

Column Properties

Property Description

Title Name of the workflow stage (e.g., "In Progress", "Review")

Accent Color Visual theme color for the column header

Card Count Number of cards currently in the column

Reordering Columns

Arrange columns to match your workflow:

1. Locate the arrow buttons (◀ ▶) in the column header

2. Click ◀ to move the column left

3. Click ▶ to move the column right



Customizing Column Colors

Each column can have a unique accent color for visual clarity:

1. Click the color picker in the column header

2. Select from the palette of 10 preset colors

3. The column header updates immediately

Deleting Columns

1. Click the 🗑 (trash) icon in the column header

2. Confirm the deletion when prompted

Important: Deleting a column also deletes all cards within it. This action cannot be

undone.



Search and Filtering

Using the Search Box

The search box provides instant filtering of cards:

1. Locate the search box in the top toolbar

2. Type any text to filter cards

3. Cards matching the search appear; others are hidden

4. Clear the search to show all cards again

What Gets Searched

The search filters cards based on:

Title - Card titles are searched (case-insensitive)

Description - Full description text is searched

Tags - All card tags are included in search

Search Tips

Search is case-insensitive: "bug" matches "Bug" and "BUG"

Partial matches work: "anim" finds "animation" and "animate"

Search updates in real-time as you type

Use specific tag names to filter by category

Pro Tip: Use consistent tag naming (e.g., "code", "art", "design") to quickly filter cards by

department or type.



Figure 3: Search functionality filtering cards in real-time



Board Management

Multiple Boards

Easy Kanban Board supports multiple saved boards per project:

Each board has its own columns, cards, and settings

Boards are saved automatically as you work

Switch between boards instantly without losing work

Board Manager

Access the Board Manager from the toolbar:

Action Description

New Board Create a new empty board

Switch Board Load a different saved board

Rename Board Change the name of the current board

Delete Board Permanently remove a board from disk

Creating a New Board

1. Click Board Manager in the toolbar

2. Click New Board

3. Enter a name for your board

4. Choose to start blank or from a template

5. Click Create



Figure 4: Board Manager interface for creating and managing boards



Figure 5: Switching between multiple saved boards

Board Templates

Quick-start your workflow with pre-configured templates:



Figure 6: Available board templates for quick-start workflows

Default Template

Columns: Backlog → To Do → In Progress → Code Review → Testing → Done

Use Case: Full software development pipeline

Pre-populated: Sample cards with common task types

TODO Template

Columns: To Do → In Progress → Done

Use Case: Simple three-stage workflow

Pre-populated: Basic example cards

Animation Template



Columns: Ideas → Research → Drafting → Editing → Review → Published

Use Case: Creative content pipeline

Pre-populated: Animation workflow examples

Importing and Exporting

Exporting a Board

1. Click Export in the toolbar

2. Choose a save location for the JSON file

3. Share the file with team members

Importing a Board

1. Click Import in the toolbar

2. Select the JSON file to import

3. The board replaces the current board (save first if needed)

Team Collaboration: Export boards to share task lists with team members. They can

import the JSON file into their own Unreal Engine projects.



Figure 7: Exporting board data to JSON for sharing with team members



Customization

Board Settings

Access board settings from the toolbar to customize the interface:

Figure 8: Board settings panel for customizing appearance

Setting Options Description



Font

Family

Urbanist, Roboto, Arial, Courier

New

Choose the typeface used throughout the

board

Font Size 8pt - 14pt Adjust text size for readability

Color Palettes

The board uses a carefully designed color system:

Dark Theme - Professional dark blue background reduces eye strain

Blue-Tinted Inputs - Light blue backgrounds on all text fields

Accent Colors - 10 distinct colors for columns and card priorities

Consistent Styling - Matches Unreal Engine's editor aesthetic



Best Practices

Organizing Your Workflow

Keep columns focused - Each column should represent a clear stage

Limit work in progress - Don't overload the "In Progress" column

Regular cleanup - Archive or delete completed cards periodically

Consistent naming - Use clear, action-oriented card titles

Tag Strategy

Category tags: code, art, design, audio, level

Priority tags: urgent, critical, nice-to-have

Status tags: blocked, review-needed, testing

Team tags: frontend, backend, qa, art-team

Workflow Examples

Game Feature Development

1. Backlog: Feature ideas and requests

2. Design: Features being designed and planned

3. Implementation: Active development work

4. Testing: QA and bug fixing

5. Polish: Final tweaks and optimization

6. Done: Shipped features

Asset Production Pipeline

1. Concept: Initial ideas and sketches

2. Modeling: 3D model creation

3. Texturing: Material and texture work



4. Rigging: Skeleton and controls setup

5. Integration: Import and setup in Unreal

6. Complete: Ready for use

Bug Tracking

1. Reported: New bug reports

2. Confirmed: Verified and reproducible

3. Fixing: Developer actively working

4. Testing: Fix verification

5. Resolved: Confirmed fixed



Troubleshooting

Common Issues

Board Not Saving

Check that your project folder is not read-only

Verify you have write permissions to the Saved folder

Look for errors in the Output Log (Window → Developer Tools → Output Log)

Cards Not Appearing

Check if search filter is active - clear the search box

Ensure cards weren't accidentally moved to another column

Verify the board file loaded correctly (check Output Log)

Drag and Drop Not Working

Try clicking and holding for half a second before dragging

Ensure you're dragging from the card body, not buttons

Check if the editor window has focus

Settings Not Persisting

Settings are saved per board - each board has its own preferences

Make sure to save the board after changing settings

Check project permissions if settings won't save

Data Location

Board data is stored in your project's Saved folder:

Default Board: YourProject/Saved/KanbanBoard.json

Named Boards: YourProject/Saved/KanbanBoard_[Name].json

Format: Human-readable JSON (can be edited manually if needed)



Getting Help

If you encounter issues:

1. Check the Output Log for error messages (filter by "LogKanbanBoard")

2. Verify your Unreal Engine version is 5.5 or higher

3. Try exporting your board and reimporting it

4. Contact support through the Fab Marketplace



Tips and Tricks

Keyboard Shortcuts

Action Shortcut

Save card in editor Enter

Cancel card edit Escape

Focus search box Ctrl+F (when board is focused)

Productivity Tips

Use color coding - Assign consistent colors to task types (red=bugs, blue=features, etc.)

Daily standup - Use the board during team meetings to discuss progress

WIP limits - Set personal limits on "In Progress" cards to avoid overcommitting

Regular reviews - Weekly review of backlog and completed items

Archive completed work - Export old boards for record-keeping

Integration with Unreal Engine

Create cards for each level that needs design work

Track blueprint implementation tasks by feature

Organize material and shader creation pipeline

Coordinate animation sequences and cutscenes

Manage sound effect and music integration

Stay Organized: The key to successful Kanban is consistency. Update your board daily

and keep it visible during development sessions.
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