
User Guide

Version 1.0.0

January 2026



Introduction

Welcome to Landstamp Pro, a professional landscape stamping plugin for Unreal Engine 5.5 that

revolutionizes terrain creation. With over 370+ high-quality heightmap stamps, you can quickly

create detailed terrain features including mountains, canyons, rivers, volcanoes, and more.

Landstamp Pro uses the native Landscape Patch system to provide non-destructive, layer-based

terrain modification. This means you can add, edit, and remove stamps without permanently

altering your base landscape, giving you complete creative freedom.

What's Included

374 Professional Heightmap Stamps - Organized into categories for easy browsing

Two Content Packs - Base pack (335 stamps) and Weapons pack (39 stamps)

Intuitive Browser Interface - Search, filter, and preview stamps in real-time

Custom Stamp Creation - Import your own heightmaps or extract from static meshes

Advanced Blending Controls - Multiple blend modes and falloff options

Priority System - Control how overlapping stamps interact with 10 priority levels

Key Features

Non-Destructive Workflow

All stamp modifications are non-destructive and layer-based. Move, rotate, scale, or delete

stamps at any time without affecting your base landscape terrain.

Extensive Stamp Library

Choose from hundreds of professionally crafted heightmap stamps organized into categories

including Mountain, Canyon, Hill, Crater, River, Volcano, Directional paths, and Creatures.

Real-Time Preview

See exactly how your stamp will look before applying it. The 3D preview viewport shows the

heightmap with proper lighting and shading.



Custom Stamp Support

Import your own PNG heightmap images or extract heightmaps directly from static meshes in

your project. Perfect for creating unique terrain features from existing assets.

Getting Started: If you're new to landscape stamping, we recommend starting with the

Quick Start Guide in the next section to create your first stamped terrain in just a few

minutes.

Quick Start Guide

This guide will walk you through creating your first stamped landscape in less than 5 minutes.

1 Create a Landscape

In your Unreal Engine level, create a new Landscape using the Landscape Mode (Shift+2) or

from the Place Actors panel. Use the default settings or customize the size to your needs.

2 Open Landstamp Pro Browser

Navigate to the main toolbar and click the Landstamp Pro button, or open it from the

Window menu: Window → Landstamp Pro Browser.

3 Browse and Select a Stamp

Use the Pack dropdown to select "Base" and browse through the available stamps. Click on

any stamp thumbnail to see a 3D preview. Try selecting a Mountain stamp to start.

4 Place the Stamp

Click the "Add to Level" button. A Landstamp Actor will be created at the world origin (0, 0,

0).

5 Position and Adjust

Select the Landstamp Actor in your viewport or outliner. Use the standard Unreal Engine



move (W), rotate (E), and scale (R) tools to position your stamp. The changes will update in

real-time on your landscape.

6 Fine-Tune Settings

In the Details panel, adjust properties like Height Intensity, Blend Mode, and Falloff Mode to

get the exact look you want.

Congratulations! You've created your first stamped terrain. Continue reading to learn

about advanced features and techniques.

Installing the Plugin

Installation from Fab Marketplace

1. Purchase and download Landstamp Pro from the Fab marketplace

2. Open the Epic Games Launcher

3. Navigate to your Unreal Engine Library

4. Find Landstamp Pro in your Vault and click Install

5. Select the engine version (5.5 or later) and click Install

6. Open your Unreal Engine project

7. Go to Edit → Plugins

8. Search for "Landstamp Pro" and enable it

9. Restart the editor when prompted

Verifying Installation

After restarting the editor, verify the plugin is installed correctly:

Check for the Landstamp Pro button in the main toolbar

Open Window → Landstamp Pro Browser - the browser window should open



In the Content Browser, navigate to Plugins → Landstamp Pro Content to see the stamp

library

Important: Landstamp Pro requires Unreal Engine 5.5 or later. The plugin uses the native

Landscape Patch system which was introduced in UE 5.5.

User Interface Overview

Landstamp Pro Browser

The Landstamp Pro Browser is the main interface for browsing, searching, and placing stamps.

Open it from Window → Landstamp Pro Browser or click the toolbar button.

Browser Layout

Section Description

Filter Bar Search by name, filter by pack and tag

Stamp Grid Thumbnail view of all available stamps

Preview Panel 3D preview of selected stamp with lighting

Info Panel Displays stamp name, category, pack, and tags

Action Buttons Add to Level, Create Custom Stamp, Refresh

Search and Filtering

Search Box: Type to search stamp names in real-time

Pack Filter: Select "All", "Base", or "Weapons" to filter by content pack

Tag Filter: Click a tag category to filter stamps (e.g., "Mountain", "River", "Alien")

Clear Filters: Click the X button to reset all filters

3D Preview Viewport

The preview viewport shows a 3D representation of the selected stamp heightmap:



Rotate: Right-click and drag to rotate the camera

Pan: Middle-mouse button and drag to pan

Zoom: Mouse wheel to zoom in/out

Reset View: Double-click to reset camera position

Landstamp Actor Details Panel

When you select a Landstamp Actor in your level, the Details panel shows all configurable

properties organized into categories.

Stamp Info Section

Property Description

Stamp Name Display name for this stamp instance

Category Stamp category (Mountain, Canyon, etc.)

Priority Priority level (1-10) for overlapping stamps

Stamp Texture Section

Property Description

Heightmap Texture The grayscale texture used for height data

Stamp Settings Section

Property Description

Blend Mode
How the stamp blends with terrain (Additive, Subtractive, Replace,

Max, Min)

Height Intensity Multiplier for stamp height (-2 to 2, negative inverts)

Stamp Size Width and height in world units (Unreal cm)



Max Height

Displacement
Maximum height change in world units

Stamp Blend Section

Property Description

Falloff Mode Shape of blend region (Circle, Rounded Rectangle, Square)

Blend Preset Quick blend distance presets (Tiny to Massive, or Manual)

Manual Blend Distance Custom blend distance (only when Blend Preset = Manual)

Stamp Transform Section

Property Description

Stamp Rotation Rotation angle in degrees (0-360)

Working with Stamps

Placing Stamps

There are multiple ways to add stamps to your landscape:

Method 1: From the Browser

1. Open the Landstamp Pro Browser

2. Select the stamp you want to place

3. Click "Add to Level"

4. The stamp actor will be created at the world origin

5. Move it to your desired location using the transform tools

Method 2: Drag and Drop from Content Browser

1. Navigate to Plugins → Landstamp Pro Content → Stamps



2. Find a Stamp Asset (DA_*)

3. Drag it into your viewport

4. A Landstamp Actor will be created at the drop location

Method 3: Place Actors Panel

1. Open the Place Actors panel

2. Search for "Landstamp"

3. Drag the Landstamp Actor into your level

4. Assign a heightmap texture in the Details panel

Transforming Stamps

Landstamp Actors behave like normal actors and can be transformed using the standard Unreal

Engine tools:

Move (W): Position the stamp anywhere on your landscape

Rotate (E): Rotate around the Z-axis, or use Stamp Rotation property for precise angles

Scale (R): Uniform or non-uniform scaling to resize the stamp footprint

Tip: Use End key (or Alt+End) to snap the stamp actor to the landscape surface for easier

positioning.

Adjusting Stamp Properties

Height Intensity

The Height Intensity property controls the strength of the stamp effect:

Positive values (0 to 2): Normal heightmap application

Negative values (-2 to 0): Inverts the heightmap (mountains become valleys)

0: No effect (useful for temporarily disabling a stamp)

Blend Modes

Mode Description Use Case



Additive Adds stamp height to terrain Mountains, hills, mounds

Subtractive Subtracts stamp height from terrain Valleys, pits, depressions

Replace Replaces terrain with stamp height Plateaus, flat areas

Max Uses maximum of stamp and terrain Preserving high points

Min Uses minimum of stamp and terrain Preserving low points

Falloff Modes

Falloff mode controls the shape of the blend region where the stamp transitions into the existing

terrain:

Circle: Smooth circular falloff - best for natural features

Rounded Rectangle: Softer corners while maintaining general shape

Square: Hard rectangular boundary - best for architectural features

Blend Presets

Blend presets automatically calculate the blend distance as a percentage of the stamp size:

Tiny (5%): Very sharp transition

Small (10%): Sharp transition

Medium (15%): Default, balanced transition

Large (25%): Smooth transition

X-Large (35%): Very smooth transition

Huge (50%): Extremely smooth transition

Massive (75%): Maximum smooth transition

Manual: Specify exact blend distance in world units

Priority System

When multiple stamps overlap, the Priority property determines which stamp appears "on top":

Priority 1 (Lowest): Renders beneath all other stamps

Priority 5 (Default): Standard priority for most stamps

Priority 10 (Highest): Always renders on top



Example Use Case: Set base terrain stamps to Priority 3, medium features to Priority 5,

and detail stamps (rocks, paths) to Priority 7-10 for proper layering.

Creating Custom Stamps

From PNG Heightmap Images

You can import your own PNG heightmap images to create custom stamps:

1 Prepare Your Heightmap

Create or obtain a grayscale PNG image where white represents high elevation and black

represents low elevation. Recommended sizes: 512x512, 1024x1024, or 2048x2048 pixels.

2 Open Custom Stamp Dialog

In the Landstamp Pro Browser, click the "Add Custom" button.

3 Select Import from PNG

Choose the "Import from PNG" option in the dialog.

4 Browse for Your Image

Click "Browse" and navigate to your PNG file. Select it and click Open.

5 Configure Stamp Settings

Enter a name, select a category, choose a pack (or create new), and add tags for

organization.

6 Create Stamp

Click "Create" to import and process the heightmap. The new stamp will appear in your

library.



From Static Mesh

Extract heightmaps directly from static meshes in your project:

1 Open Custom Stamp Dialog

Click "Add Custom" in the Landstamp Pro Browser.

2 Select Extract from Mesh

Choose the "Extract from Mesh" option.

3 Pick a Static Mesh

Use the asset picker to select the static mesh you want to extract from.

4 Choose Projection Axis

Select which axis to project from (usually Z-axis for top-down view). Preview the extraction

in the viewport.

5 Set Resolution

Choose the output resolution (512, 1024, or 2048). Higher resolutions preserve more detail

but use more memory.

6 Configure and Create

Enter name, category, pack, and tags, then click "Create" to generate the stamp.

Note: Mesh extraction works best with detailed meshes that have clear height variation.

Simple or low-poly meshes may produce basic heightmaps.



Workflow Tips and Best Practices

Landscape Preparation

Start with a flat or gently sculpted base landscape before adding stamps

Use a landscape size that accommodates your planned stamp placement

Consider enabling World Partition for large landscapes with many stamps

Stamp Placement Strategy

1. Plan Your Layout: Sketch out major terrain features before placing stamps

2. Start Large: Place large mountains, valleys, and terrain features first

3. Add Medium Details: Add hills, small canyons, and connecting features

4. Finish with Details: Use small stamps for rocks, paths, and fine details

Blending and Layering

Use appropriate falloff: Natural features benefit from larger blend distances

Vary stamp rotation: Rotate stamps to avoid repetitive patterns

Overlap strategically: Overlapping stamps can create complex, realistic terrain

Layer with priority: Use the 10-level priority system to control stamp layering

Performance Optimization

Use appropriate stamp sizes: Don't use massive stamps for small details

Limit simultaneous edits: Work on one area at a time to maintain good performance

Clean up unused stamps: Delete stamps you're not using to reduce memory usage

Organization

Name your stamps: Give each Landstamp Actor a descriptive name in the outliner

Use folders: Organize stamps into folders by region or feature type

Document your work: Add comments or notes about complex stamp arrangements



Pro Tip: Create a "stamp template" level with common configurations you use frequently.

Copy and paste stamp actors from this template to save time on new projects.

Troubleshooting

Common Issues and Solutions

Stamp not appearing on landscape

Ensure the stamp actor is positioned above the landscape (check Z position)

Verify Height Intensity is not set to 0

Check that a valid heightmap texture is assigned

Confirm the landscape is within the stamp's influence area

Stamps look blocky or pixelated

The stamp size may be too large for the heightmap resolution

Try using a smaller stamp size or higher resolution heightmap

Check the heightmap texture import settings (should not be compressed for normal maps)

Overlapping stamps produce unexpected results

Adjust the Priority property to control which stamp appears on top

Check the Blend Mode settings for each stamp

Increase the Blend Preset for smoother transitions between stamps

Performance is slow when placing stamps

Reduce the number of stamps being edited simultaneously

Use simpler falloff modes (Circle is fastest)

Lower the landscape resolution if possible

Ensure your computer meets the minimum requirements for UE 5.5

Custom stamp import fails



Verify the PNG image is grayscale (RGB images may import incorrectly)

Check that the image size is a power of 2 (512, 1024, 2048, etc.)

Ensure the file path doesn't contain special characters

Try re-exporting the image from your image editor

Getting Support

If you encounter issues not covered in this guide:

Check the Landstamp Pro documentation on Fab marketplace

Visit the support forum for community help

Contact Mythic Lemon support with detailed information about your issue

Frequently Asked Questions

Can I use Landstamp Pro in commercial projects?

Yes! Once purchased, you can use Landstamp Pro and all included stamps in any commercial or

personal projects without additional fees or royalties.

Does it work with World Partition?

Yes, Landstamp Pro is fully compatible with World Partition and can be used on large landscapes

divided into streaming regions.

Can I export my stamped landscapes?

Yes, you can export the final landscape heightmap using Unreal Engine's standard landscape

export tools. The stamps are applied to the landscape and become part of the terrain data.

How many stamps can I place in a single level?

There's no hard limit, but performance depends on your hardware and stamp complexity. Most

users can comfortably work with dozens to hundreds of stamps on modern hardware.

Can I share custom stamps with my team?

Yes! Custom stamp assets are stored in your project's content folder and can be committed to

source control and shared with your team.



Does it work with Nanite landscapes?

Landstamp Pro works with the standard UE5.5 landscape system. When Nanite landscape

support becomes available, we will update the plugin to support it.

Can I paint materials/layers with stamps?

Currently, Landstamp Pro only modifies landscape height. Material/layer painting support is

planned for a future update.
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